Ducati DesertX Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Just got the bike friday, was able to select different riding modes very easily. Saturday bike is stuck in touring mode and won't let me select anything different. Anyone had this problem or know how to reset system possibly?
 

·
Registered
Joined
·
4 Posts
Thanks for the input @cleatus.maximus and welcome! @PelhamX have yo tried this with your bike?
[/
Welcome to the forum, thanks for the info!
How long have you had your DesertX for? Thoughts on the ride modes (if you spent enough time going through them)?
Just got mine on Tuesday. I had it in "wet" mode for the ride home from the dealer, will be trying out "touring" on next ride....
 

·
Registered
Joined
·
21 Posts
Yup, doing the hold for 3-5 seconds and it totally bypasses the mode and goes into the further selections you can make like ABS and power settings. Getting a little frustrated, might have to go back to the dealer.
Hi.
Yup, doing the hold for 3-5 seconds and it totally bypasses the mode and goes into the further selections you can make like ABS and power settings. Getting a little frustrated, might have to go back to the dealer.
Just got the bike friday, was able to select different riding modes very easily. Saturday bike is stuck in touring mode and won't let me select anything different. Anyone had this problem or know how to reset system possibly?
Hi. I've just uploaded a short video to you tube. I'm no expert but hope it helps.
 

·
Registered
Joined
·
2 Posts
Yup, doing the hold for 3-5 seconds and it totally bypasses the mode and goes into the further selections you can make like ABS and power settings. Getting a little frustrated, might have to go back to the dealer.
Me too. Done 4000 km on mine and used all modes and it’s now doing the same as yours. Have no fix. Today I couldn’t even get to a mode selection. It’s was blank up the top with only the timer available. Obviously when in cruise control it won’t let you Surely there’s something we can do
 

·
Registered
Joined
·
4 Posts
Anyone figure this out? Mine is under 200 miles and is not switching as well. It did once... Just clicks over into adjustments. maybe I was not closing the throttle enough- will try again tomorrow. Checked all fuses are good, doesn't seem to be a fuse issue unless the box is bad. No hazard lights like in the Australia video.
 

·
Registered
Joined
·
4 Posts
Ok so i figured out that it must be selected by holding the mode button from the main display (with the speedo or rally mode display) not from the settings menu. If you turn on the bike and let the normal screen appear, then hold the mode or enter button about 3 seconds, it will bring up the riding mode menu, then a quick tap to select. Throttle must be actively shut and breaks NOT applied. It will only let you tune the modes if you access it through the settings. - hope this helps.
 
1 - 16 of 16 Posts
Top